Native Instruments ends support for OSX 10.6.8 Snow Leopard

So, we say our software package is compatible with 10.6.8, and it is.  The software we provide is compatible, including Native Instruments, SampleTank, TriplePlay, Progression and Studio One.  Unfortunately, for our provided NI factory patches to work within our TriplePlay software, it requires updating the product within their Service Center program (the Native instruments registration and update software).  Specifically, TriplePlay needs the Reaktor Player 5.8 or higher update to work properly.  However, Native Instruments has just released update 5.9.  That is fine, unless you’re using Snow Leopard, because 5.9 is no longer compatible.  You’re put in an awkward position, because you need the update for TriplePlay to work, but NI no longer provides the update you need, if you’re a 10.6.8 Snow Leopard user.  What to do?

I went on the NI site and couldn’t find this legacy updater.  But, we’ve posted a copy online here: reaktor_5.8_update.dmg

10.6.8 users can download this legacy updater and get full functionality from NI with their TriplePlay software default patches.

Native Instruments Service Center

SIGN UP FOR THE FISHMAN NEWSLETTER